td_histoire_numerique:installation_db_2013
Différences
Ci-dessous, les différences entre deux révisions de la page.
| Les deux révisions précédentesRévision précédenteProchaine révision | Révision précédente | ||
| td_histoire_numerique:installation_db_2013 [2016/01/15 08:06] – [Maintenant il faut l'interface] fberetta | td_histoire_numerique:installation_db_2013 [2016/01/26 23:19] (Version actuelle) – [Pour Macintosh] fberetta | ||
|---|---|---|---|
| Ligne 4: | Ligne 4: | ||
| =====Installation de la base de données===== | =====Installation de la base de données===== | ||
| - | Téléchargez le fichier | + | Téléchargez le fichier qui contient le code de la base de données {{: |
| Dézippez-le. | Dézippez-le. | ||
| Ligne 10: | Ligne 10: | ||
| Ouvrez l' | Ouvrez l' | ||
| - | Sélectionnez Bases de données. Puis dans le menu Edition > Créer ou click droit et ajouter une base de données | + | Sélectionnez Bases de données. Puis dans le menu Edition > Créer ou clic droit et ajouter une base de données |
| * Création d'une nouvelle base de données : l' | * Création d'une nouvelle base de données : l' | ||
| * Définissez le codage des caractères : onglet Définition > codage UTF8 | * Définissez le codage des caractères : onglet Définition > codage UTF8 | ||
| - | * bouton OK | + | * Bouton " |
| - | Sélectionnez la base de données ' | + | Sélectionnez la base de données ' |
| - | * clicquez | + | * cliquez |
| * Effacez le texte qu'il contient éventuellement | * Effacez le texte qu'il contient éventuellement | ||
| * Ouvrez les fichiers à installer avec la commande ouvrir qui se trouve dans le menu Fichier > Ouvrir | * Ouvrez les fichiers à installer avec la commande ouvrir qui se trouve dans le menu Fichier > Ouvrir | ||
| * Si le logiciel vous demande si vous voulez sauvegarder le texte que vous venez d' | * Si le logiciel vous demande si vous voulez sauvegarder le texte que vous venez d' | ||
| * Ouvrir dans le dossier dezippé > dossier ' | * Ouvrir dans le dossier dezippé > dossier ' | ||
| - | * Une fois le fichier ouvert, exécuter avec le menu Requêtes > Exécuter ou avec le bouton avec la forme d' | + | * Une fois le fichier ouvert, exécuter avec le menu Requêtes > Exécuter ou avec le bouton avec la forme d' |
| * Vous regardez la dernière ligne du message : "La requête a été exécutée avec succès en 391 ms, mais ne renvoie aucun résultat." | * Vous regardez la dernière ligne du message : "La requête a été exécutée avec succès en 391 ms, mais ne renvoie aucun résultat." | ||
| * Vous répétez ensuite l' | * Vous répétez ensuite l' | ||
| * ATTENTION : exécuter les quatre fichiers .sql exactement DANS L' | * ATTENTION : exécuter les quatre fichiers .sql exactement DANS L' | ||
| * Fermez la boîte de dialogue SQL. Si le logiciel vous demande si vous voulez sauvegarder le texte que vous venez d' | * Fermez la boîte de dialogue SQL. Si le logiciel vous demande si vous voulez sauvegarder le texte que vous venez d' | ||
| - | * Sélectionner le dossier ' | + | * Sélectionner le dossier ' |
| - | * quatre | + | * Quatre |
| - | * Par exemple, ouvrir le schéma ' | + | * Par exemple, ouvrir le schéma ' |
| Ligne 44: | Ligne 44: | ||
| * Ce dossier est à télécharger ici : {{: | * Ce dossier est à télécharger ici : {{: | ||
| - | * A son intérieur, on trouve un dossier appelé ' | + | * À l'intérieur, on trouve un dossier appelé ' |
| * Dans ce dossier se trouve un fichier " | * Dans ce dossier se trouve un fichier " | ||
| - | * mettre | + | * Mettre |
| - | * remplacer le mot passe (MODIFIER ou NN) par son propre | + | * À la même ligne, |
| + | * Dans la fonction " | ||
| * Ensuite sauvegarder et fermer. | * Ensuite sauvegarder et fermer. | ||
| Ligne 54: | Ligne 55: | ||
| ==== Pour Windows ==== | ==== Pour Windows ==== | ||
| - | * Chercher le dossier dans lequel a été installé PostgreSQL, normalement C: | + | * Chercher le dossier dans lequel a été installé |
| * Dans ce dossier se trouve un dossier ' | * Dans ce dossier se trouve un dossier ' | ||
| * Normalement, | * Normalement, | ||
| - | * Mettre dans ce dossier (htdocs) le dossier 'base_indiduelle' avec le fichier et mot de passe modifié | + | * Mettre dans ce dossier (htdocs) le dossier 'base_individuelle' avec le fichier et mot de passe modifié |
| - | * Ouvrir un navigateur et taper l' | + | * Ouvrir un navigateur et taper l' |
| ==== Pour Macintosh ==== | ==== Pour Macintosh ==== | ||
| - | * Chercher le dossier dans lequel a été installé PostgreSQL, normalement / | + | * Chercher le dossier dans lequel a été installé |
| * Dans ce dossier se trouve un dossier apache2 contenant à son tour un dossier ' | * Dans ce dossier se trouve un dossier apache2 contenant à son tour un dossier ' | ||
| * Normalement, | * Normalement, | ||
| Ligne 72: | Ligne 73: | ||
| - | **Voilà**, c'est fait ! Vous pouvez maintenant | + | **Voilà**, c'est fait ! Vous pouvez maintenant |
| + | \\ | ||
| + | |||
| + | ===== Installation d'une base donnée remplie ===== | ||
| + | |||
| + | Le {{: | ||
| + | |||
| + | \\ | ||
| + | ===== Mise en place d'une connexion avec la BHP du projet SyMoGIH ===== | ||
| + | [en cours, ne pas utiliser] | ||
| * Enfin, exécutez le fichier SQL ' | * Enfin, exécutez le fichier SQL ' | ||
td_histoire_numerique/installation_db_2013.1452841579.txt.gz · Dernière modification : de fberetta
